Summary
A server running Citrix Presentation Server cannot acquire a license.
Cause
In this example, the environment contains two license servers—one active in the production environment and one on standby as a backup (the backup license server has the same name and licenses, but is shut down).
If you temporarily switch from the production license server to the backup license server and then switch back to the original license server, some servers might not be able to acquire a license.
Resolution
1. Verify that the license server is listening on the correct IP address and is not listening to the backup license server due to a wrong entry in the Domain Name System (DNS) cache (both servers have the same name, but have different IP addresses).
2. If the license server is not listening on the correct IP address, flush the DNS cache.
3. Network issues may be preventing servers from resolving the license server name. In this case, point to the Fully Qualified Domain Name (FQDN) for the license server and not just the machine name.